CompatInfo 3.6.0 has just been released.

News :

  • Support new stable PHP versions 5.6.3, 5.5.19 and 5.4.35

  • The reference:show command may now display list of releases of a reference.

  • add a W mark in front of element that have PHP versions excluded on reference:show command.

  • improved PHP 5.6 detection with request GH-140 (constant scalar expressions).

  • improved PHP 5.6 detection with request GH-141 (variadic functions expressions).

  • improved PHP 5.6 detection with request GH-142 (exponentiation expressions).

  • improved PHP 5.6 detection with request GH-143 (use const, use function expressions).

Changes :

  • when you run tests with phpunit.xml and tests\bootstrap.dev.php, it won’t stop even if growl server is down (or not installed).

  • tests\bootstrap.dev.php logs now results using the Monolog RotatingFileHandler and keep a 30 days history.

  • split autoload src and tests files in composer.json

  • The validate command can detect schema violations. See Reflect 2.6 and justinrainbow/json-schema dependency.

Bugs :

  • GH-139 : LogPlugin works now

Download :

Published by Laurent Laville on 2014-11-13